您的 PHP 似乎没有安装运行 WordPress 所必需的 MySQL 扩展错误解决办法

发布于 2013-12-20  857 次阅读


学校论坛服务器流量一大就崩溃,寻思着给web环境升下级

然后吧Apache换成了nginx/1.5.7,

mysql升到了5.6.12

php升到了5.4.23

升级完成后兴冲冲的打开一看提示您的 PHP 似乎没有安装运行 WordPress 所必需的 MySQL 扩展

(论坛装了WordPress 

立马百度,更具下面的方法解决的

第一步:
确认开启以下扩展
extension=php_mysql.dll
extension=php_mysqli.dll
第二步:
找到
; On windows:
; extension_dir = "ext"
去除前面的分号,并改为
extension_dir = "D:/php5/ext"
D:/php5为你的php安装目录
注意:把D:php5改为D:/php5,即路径中所有的都改为/

 

ok,一切正常


因为喜欢所以折腾。。。